About GT6 Multi-Block


(ProperSAMA) #1

I’m sorry I have so many questions…
Because it has nothing to do with previous questions, I chose to new Topic.
When I build multi-block structures(like coke oven) in multiplayer games.Often, placed blocks disappear.
I think it may be difficult to explain just by text, so upload a gif.


Because I can’t upload images larger than 5M, FPS is very low.
As shown in the picture, when I placed the block, the previously placed block disappeared.
Only in multiplayer games, not in single games.
Only multi-block structures blocks can do this.
In the picture, I used Wood Wall.This is also the case with Fire Bricks.
I deleted all Mods and plugins except GT6.But the block will still disappear.

This server is running KCauldron version 1.7.10-R0.1-SNAPSHOT (MC: 1.7.10) (Implementing API version 1.7.10-R0.1-SNAPSHOT)
I’m sure I did put that block.The block in the inv did run out.


(Gregorius Techneticies) #2

Lets see how well i can write on this mini keyboard

does the placed block still exist or is it gone entirely?

also serverside log files might help ^^


(ProperSAMA) #3

I think it’s completely gone.
The server did not output any errors or anything else.


(Gregorius Techneticies) #4

can you try placing the block a second time? Maybe KCauldron just invalidated your block placement and you actually still hold the block in your hand?


(ProperSAMA) #5

I tried several more times. It seems that the block was really consumed and never returned to my inventory.


(Gregorius Techneticies) #6

Okay I really need the Serverside Logs for that one, otherwise I cant help. :wink:


(ProperSAMA) #7

logs.zip (298.0 KB)
That’s all.
I gave myself some blocks with NEI.Put down 9 blocks.One of them disappeared.Maybe the penultimate one? I can’t remember.
After about 10 seconds, I sent “now” in the chat bar.It wasn’t long before I shut down the server.
I didn’t see any information that might be relevant…
I might ignore something, so upload it here.

In addition, it seems that not only multi-block blocks will disappear.If I put the blocks quickly, it seems that all GT6 blocks will disappear.
But at the same speed, other mod blocks do not have this situation.


(TWEENER) #8

In fact, it’s a problem with the server plug-in KC. I replaced it with something else on one of my servers, and it hasn’t happened since then.
In addition, I have a lot of questions about GT6 machine formula. Do you have time to talk with me for a long time?


(ProperSAMA) #9

But I don’t have any plugins installed on my server…

Now I have time, you can ask me, I will tell you what I know.
But,Your English seems to come from computer translation, too.
Can you tell me which country you come from?It would be funny if I was using a computer translation to communicate with a person from the same country.^^


(TWEENER) #10

I am come from China.It’s really interesting.
When I wrote the MTU statement, the NEI in the game was not displayed. This may be related to the error warning about MTU in the chat bar when I enter the game. I tried to replicate the success sentences yourhowed, but it didn’t work for me.


(TWEENER) #11

Didn’t you say you installed KC?


(ProperSAMA) #12

插件翻译成plug-in,合成公式翻译成formula,和我输中文进去百度翻译输出的英文一模一样XD
QQ997794945详聊


(Gregorius Techneticies) #13

if you click on someones profile icon you can see what they entered in the " Spoken Languages" Field. I added it for a reason. :wink:

Downloaded the Logs and will look at them once I am done installing and testing stuff on my new GPD Win 2.


(ProperSAMA) #14

Thanks! I hope this will help you.


(Mr.CHEN) #15

For computer translation, I will “manually” repair some imprecise translations to make sentences more natural and ambiguous.
By the way, when it comes to GT6’s multiblock, I’m looking forward to multiblock electrolyzer and other things… Recently, however, Greg has not been in the mood to update the copyright bill because of its annoyance. Maybe next week?


(ProperSAMA) #16

Thanks to TWEENER, I replaced other server cores.The problem does not seem to recur.
This server cores is Thermos, hoping to help others.
Thermos is optimized by KCauldron, and maybe some optimization solves this problem.


(Gregorius Techneticies) #17

Yeah I am slowly feeling better, now that there is literally nothing that can prevent it anymore, “uncertainty” gets me at times. :confused:

This week will still mostly be Bugfixes but I think I will actually do stuff next week for sure.

Will probably make a post in off-topic about the tiny laptop I received in the mail today, so far it works well but I still need to configure a bunch of things. I didn’t even insert the Micro SD card I bought for it yet for extra non-encrypted storage.


(Gregorius Techneticies) #18

I looked at the Logs just now, there is nothing hinting on a “crash being voided”, so something in KCauldron is causing this issue all by itself and I dont know what it is and cant really fix it. :confused:

But I see you got a replacement for the Server Plugin Stuffs that works fine, so i guess its fixed on your end?


(ProperSAMA) #19

Thermos can basically replace KCauldron, but some plugins are not available.
We can’t do anything without error logs, but thank you anyway:sweat_smile:


(system) automatically bumped #20