Minecraft lags even at the menu without any other than Forge and Gregtech mods

Minecraft lags even at the menu without any other than Forge and Gregtech mods
0

Hello,

I’ve tried clean install of Forge, change arguments of Java, versions of it to no result. It consumes much cpu and memory even at menu. I’ve noticed that it’s removal of Gregtech fixes this. I’ve tried gregtech_1.7.10-6.10.21.jar and
gregtech_1.7.10-6.08.00.jar. Both are lagging.
My config is:
AMD fx-8320e @ 4.2GHz
8Gb RAM
AMD Radeon R9 290

Possible mitigation:
Force Vsync off in radeon settings (or nvidia panel) nearly doubles FPS. Please add this to FAQ, i think many will find this useful.

2 Likes

This cant be right, I am running “Just GT6, NEI and Forge” with 1.1GHz and 1GB of RAM on my own Device.

Are you sure that nothing is running in the background? Like other Games or random Ghost instances of Java that Minecraft likes to create sometimes.

1 Like

No, i’ve checked many times and even restarted, RAM is plenty, so is CPU. Loading itself takes less than minute.

EDIT:
Setting Mipmap to 0 from 4 helped. Still it’s barely over 40 FPS with 100% single core occupancy.

2 Likes

So what kind of lag are you talking about? stuttering? unresponsive UI? just Frames per Second being wonky?

Aaaaand I just saw your Edit while writing this. Yes Mipmapping can do this when there is a lot of Textures, why did you even put it that far up?

1 Like

Lag is like it’s missing some frames. Buttons in menu being selected in second or two instead of near instantly, so it’s unresponsible UI. But in a game it’s also wonky, i guess.
4 was the system default. My last setup with significant ammount of mods was with mipmap 1 and it still lagged alot.
Still around 1.5 Gb of memory in menu, which is strange. I have Java Mission Controll Installed, if that will help.

2 Likes

Yeah this is an Issue because GT6 has so many Textures, the only way to fix that would be to remove Content or to fix the crappy Code Base that Minecraft is, neither of which is going to happen.

Since it is FPS Lag, what is your Graphical RAM size? That’s purely on your GPU end, maybe your GPU has not enough RAM to run with that many Textures.

1 Like

It’s 4Gb, i think that’s more than enough with default texturepack. It’s currenly uses about 1,800mb dedicated and 65mb of D3D memory.

2 Likes

Darn, that means there is some other graphics Issue, and ofcourse I do not know that much about Graphics. Let me summon @OvermindDL1 here to see if he knows what the f is going on.

1 Like

Sure thing, thank you. I’m afraid, i’m done for today. Please tell me what do need from my end and in a few days i’ll post it.

To be clear:
Cpu is ~6% and RAM is around 1.5Gb and <1Gb of VRAM (103mb of D3D, but since it’s opengl not sure that counts) at the menu. In the empty world it consumes whole module (25% of CPU) to get ~40 frames and lags like hell when i try to render new chunks. Gpu is 25% or less loaded while in low3D.

Hope this helps.

2 Likes

In this case Optifine could help, when installing it you can attempt disabling animations.
That is at least on the GPU side a lot of lag disapearing. (Animations lag out the GPU so much because they cause so much constant traffic)

2 Likes

Hello,

GPU memory consumption Dedicated and Dynamic:
standby 264 32
menu 367 96
New world 425 101

GPU usage is fairly low.
Optifine makes lags a little less irritating, but won’t fix it.
26|690x387

1 Like

Have you tried a lower Render Distance? That right there looks quite far.

1 Like

Honestly sounds to me like either some other program has hookd in the system (bad antivirus or something).

1 Like

Minecraft uses whole module (single thread for regular CPUs) and nor CPU, nor RAM, nor GPU are still not fully loaded. I doubt that AV would cause memory and CPU hoarding in menu.


That’s lowest possible render distance (2) and none difference to FPS.

EDIT:
Tried on other PC with win7, everything is OK. Deleted all other versions of Java (exept jdk-10.0.2). Still same memory leak. 32bit version won’t even start runoutofmemory(). Any ideas where to look?

EDIT2:
Reinstalled video drivers, no difference on cpu and memory consumption.

2 Likes

You seem to be willing to install a lot of stuff to make it work, may I recommend dualbooting with Linux? XD

Also MC 1.7.10 should require Java 8 by the way.

2 Likes

I think i’m going to do a clean install soon, for start win10, if not then i’ll try something like ubuntu. That’s really strange, i’ll try to load from that win7 from my main pc and see if that helps.
BTW i have latest version of java 8.

Fresh Start done nothing.

Ok. Finally.
Force Vsync off in radeon settings nearly doubles FPS. Great. Please add this to FAQ, i think many will find this useful.

2 Likes

Added a Line to the Install Instructions containing possible fixes for Graphical Lag.

2 Likes

That sounds like there isn’t enough work to have the GPU go into full speed mode, so it is staying in low-power mode until there is actually more rendering work to do then. Is this a laptop or do you have the AMD power management stuff enabled (which is generally good, a GPU at full load can consume a LOT of watts).

2 Likes