Possible Bug with miniature nether portals

Possible Bug with miniature nether portals
0

I was messing around with miniatures nether portal but I probably found a bug.

I was trying to use them for my crucible and I initially succed to link them to multiple molds. At some point i decided to move the portals but then that was when the problems begin. The chunks where properly loaded at all time , both in nether and overworld.

I removed all the portals but then when I lit the first one again it says it links to another one but there are no portal placed in the nether.

I think you can “easly” replicate this problem.

If i understood correctily you have to do the following:

1)Lit 1 portal in overworld.
2) Place 2 portals in the nether as if you want to relay any kind of signal/items/etc back to overworld. 3)Place a second portal in overworld and lit it. Till here usually everything works fine and I am able to relay any kind of signal.
4)Then place multiple portals next to the firtst one. Here things start to behave funny.
I tried to relay a redstone signal. If you lit multiple portals quickly and put a lamp where the signal came out, you can initially see all the lamps on but then they switch off sequentially ultill onlythe last placed one stays on.
5) At this point remove ALL portal.
6) Place the first one again in the same position. It will now link to the previos portal in the nether even if there are no portals in the nether anymore
7) At this point everything stop working properly.

3 Likes

The Redstone Signal only goes to the closest Portal as you might have seen on the Screenshot I initially linked. Pushing (like Redstone) comes out only one Portal, Pulling (like Molds) goes out any Portal.

Use a Magnifying Glass to check if the portals are really still connected or if the Redstone on the Lamp just didnt update during the Disconnect (the Redstone thing may be a bug).

3 Likes

Ok, I didn’t understood correctly about the pulling/pushing. This evening I will check more carefully with the magnifying glass, but when I was relitting the portal the coordinate of the old link were showing in the chat, even if the second portal was no present anymore.

Then in my survival world it happened more than once that the same setup was initially working and then it stopped for some reason that I’m not really sure about without changing anything (maybe relogging or moving away from the area and then coming back was the problem idk).

I will do more testing and I will let you know.

3 Likes

Is the Nether Side of the Portal Chunkloaded?

3 Likes

Yes, both sides were chunkloaded. I tried to unload and reload but the problem persisted.

EDIT:

Ok i think I got it to work know now. As you can see the thermometers read the temp correctly and only one 1 redston signal is able to go through. I will let you know if I get some strange behaviour again

EDIT 2 : No, there is some bug here for sure. My setup is randomly stopping working WITHOUT touching it. It happens after a relog and randomly start to work again if you relog again few times.

Could it be related to the first time the portal loads?

One strange thing is that the thermomethesr show the temp slowly going down and not going directly to ambient temp when it lost the connection to the other portal :thinking:.

3 Likes

Redstone only goes towards one of the many portals its a “Many Input Portals to One Output Portal” for Redstone. While Sensors are “Pull from many Portals and get whats at Output Portal”

So a few examples:
Redstone is Push
Item Pipes are Push
Fluid Pipes are Push
Sensors are Pull
Molds are Pull
The Top Side of Hoppers is Pull
The Output of Hoppers is Push

3 Likes

Im not talking about redstone now. Im talking about a thermometer and molds attached to the output portal that initially were working perfectly but after a relog they didnt. So in this case bot of them are “Pulling” items. I should have been more precise in my edit.

3 Likes

Okay I did something to try to fix this Issue in the Version I release later today, so this might be fixed.

Did I mention how i seriously hate Minecrafts Chunk Loading System?

3 Likes

Yes it is a mess. Many mods have problem with that

3 Likes

Why is this not being bumped by System like all other unsolved Support things? @OvermindDL1

@Corax Have you got a Solution for your Issue. after updating? I know I did something in the recent update but you have to tell me if it works. :wink:

3 Likes

Well, I hadn’t a lot of time to play these days but I didnt have any problem after the update. I will test more carefully this evening!

EDIT: Nope, I was wrong. Still the same problem. Everithing works fine, then I relog and it stops working. I have to restart the game to fix it. I think it happens only on relog. Then ,again, even if the link between portalts is gone, thermomethers still read temperature from some block that slowly goes down from the initial reading.

3 Likes

Looks like because a post was edited a little earlier, and edits already cause a bump of the thread?

2 Likes

Edits dont always bump, and that edit was way more than a day ago.

2 Likes

Unless you turned it off, they do. ^.^

Otherwise as for the bot, no clue, if you found a bug and can reproduce it, should report it! ^.^

2 Likes

Welp, I dont see how I can fix that stupid Issue… Gonna add this to the Later Category too since I cant figure it out.

3 Likes