Possibly About Chunk Load


(ProperSAMA) #1

I don’t know whether I should be happy or sad…In short, long time no see.:sweat_smile:
In my server, there was a problem.
If the player and GT6 machine are not in the same chunk(16*16).The machine won’t work properly.
The view-distance of the server is set to 3.It’s a small area, but it shouldn’t be so small.
Is this related to the setup of GT6?


(Gregorius Techneticies) #2

That is purely related to the Server itself being misconfigured. See a view distance of 3 chunks means you have a 5x5 of loaded Chunks. But TileEntities and Entities only work when the 5x5 of Chunks around them is loaded, essentially resulting in only ONE chunk being loaded at a time. So do a +2 on your chunk range or get some Chunk Loader in the Chunk with the Machines.


(ProperSAMA) #3

Thanks!I’ll test it later.
I always thought 3 was three chunks…

Edit:
I think it’s not just about view-distance.Because the same settings were used when IC2 was used before.But that did not happen.
But I think I should try it.


(Gregorius Techneticies) #4

IC2 Machines might end up Chunkloading themselves in some Situations so that could have been the Issue.


(ProperSAMA) #5

I just had some more tests.
Setting view-distance to 5 still causes this problem.
No matter how close the machine is to me.As long as I’m not in the same chunk as the machine.This problem will happen.
After many tests,I’m sure this problem is not related to GT6 config, modified recipes and server settings.
Whether I’m in the main world, near my birthplace or not, and whether the server has plugins installed, as long as I’m not in the same chunk as the machine, this problem will occur.
But this never happens in single-player games.It doesn’t appear on IC2 machines either.
Do you have any way to solve this problem?


(Gregorius Techneticies) #6

What kinda Plugins does your Server have? Maybe something just stops my Machines from ticking for no reason.


(ProperSAMA) #7

During the test, I did not install any plug-ins other than Multiverse-Core.
This plugin is used to create a new world. I don’t think it should have such an impact.


(Gregorius Techneticies) #8

Alone having certain Plugins can break the game in unpredictable ways. Heck even having Bukkit, Cauldron, whatever installed breaks a lot of Mods. I always recommend not using those things on Servers and just use actual Mods for claiming Chunks and stuff.


(ProperSAMA) #9

But in practice, these things are often very useful.
Many plugins are more useful than mod in servers, and many plugins can’t even use existing mod alternatives.
So is it possible to solve this problem in a way similar to IC2 or other mods?


(Gregorius Techneticies) #10

I do not even know what the heck the Problem actually is. All i know is that something does not tick right as soon as you leave the Chunk, and that cannot be GT6s fault.


(ProperSAMA) #11

Ok…It seems that I can only accept all this.
If there are any new findings on this issue, I will let you know in time.


(Gregorius Techneticies) #12

Hrrm, do GT6 Fluid Pipes still work when you leave the Chunk? You will need to test that with IC2 Fluid Emitting and receiving Machines.

GT6 Fluid Pipes use a different Tick Handler for actually transferring the Fluid and I would like to know if that works.


(ProperSAMA) #13

I think Fluid Pipes probably doesn’t have this problem.
I made a simple structure to test your ideas.


As you can see, a pipe left the chunk.This Shredder works properly.

Edit:
I don’t know if such a test is effective.But I only thought of this method.
In my time zone, it’s morning now. I stayed up all night.I think I have to go to bed.
I hope these tests will help you!:grin:


(Gregorius Techneticies) #14

That means my custom Tick handler works but the Vanilla Tick Handler that does all TileEntities does not. Something is fucking up the System. This is why I always disrecommend usage of KCauldron and Thermos, because they fuck this shit up royally and Modders like me cant fix it.

What do you need Thermos and KCauldron even for? claiming Chunks is already possible with regular Mods that dont fuck up the System, pregenerating Chunks too, same for keeping Chunks loaded and having permissions.


(ProperSAMA) #15

Thermos and KCauldron can install bukkit plugins, while forge alone cannot install bukkit plugins.
A lot of content is achieved through bukkit plugins. Making a bukkit plugin is much simpler than making a mod.That’s why plugin developers are far more numerous than mod developers.
Game menus, block break log, auction houses, more worlds, free building areas…Many things can be easily solved with plugins.


(Gregorius Techneticies) #16

GT6 has its own Block Break Log without any Addons needed. Mystcraft can do more Worlds and one of the CoFH Mods can do Building Areas.

Auction Houses and Game Menus I dont know though.

And all of those Plugins come at the cost of breaking Mods, so you either have easy Plugins with broken Mods or you have better Addons with working Mods.

So if this Chunk Loading Issue happens even when there is no Plugins, then Thermos/KCauldron themselves are the Problem, because of fucking up the TileEntity ticks.


(ProperSAMA) #17

Plugins and mods have different advantages, and there is a price to pay for having the advantages of both…
It seems that I can only accept all this at present.:pensive:


(Gregorius Techneticies) #18

So I assume its not a random Plugin causing the Issue? Did you test that? Like only have Thermos/KCauldron installed and NO PLUGINS alongside? Maybe its one of the Plugins doing that.


(ProperSAMA) #19

When I tested, no plugins were installed.
Besides, it seems that only turbines(Generating RU) can cause this problem?
I tried the engine(Generating KU) again and there was no problem.
I am afraid that translation will lead to misunderstanding, so the energy generated by tagging.


(Gregorius Techneticies) #20

Wait what? You said something way different earlier, I thought every single TileEntity was broken.

So what exactly is broken actually? Screenshots again please.

But if its what you have on your Screenshot up above, are you sure your Turbine produces enough Energy to power the Shredder?